elephpant-1 Lo scorso 11 luglio 2013 sul sito php.net http://www.php.net/archive/2013.php (PHP 5.3.27 Released – PHP 5.3 Reaching End of Life) viene dato l’annuncio da parte del team di sviluppatori  PHP: dell’ultimo aggiornamento della versione 5.3

La serie di PHP 5.3 riceverà aggiornamenti di sicurezza solo fino al prossimo anno, quindi l’invito da parte degli stessi ad aggiornare alla successive 5.4 o alla 5.5.

La nostra decisione parte da qui: lasciare dunque scegliere a voi, nei piani di hosting Netsons pensati per gli sviluppatori, quale versione del PHP utilizzare, in base ovviamente alle vostre esigenze professionali.

Potrete decidere di lavorare in un ambiente di sviluppo PHP 5.3 o 5.4 o 5.5, tutto questo grazie all’introduzione, nel pannello di controllo cPanel, di una nuova e unica funzionalità: “Select PHP version”.

La stessa funzionalità è stata introdotta all’interno di Plesk su Hosting Business Windows recandosi su: Plesk (https://www.dominio.tld:8443) >> Siti web e Domini >> Impostazione PHP

Il PHP Selector è un componente che troverete esclusivamente sui nostri piani di Hosting Fast e Hosting Business e che vi consentirà, come avrete già intuito, di selezionare autonomamente la versione e i moduli PHP da utilizzare. Vi ricordiamo comunque che rimanere ancorati ad una versione del linguaggio potrebbe, a lungo andare, comportare non pochi svantaggi in quanto non si godrà più del supporto da parte degli sviluppatori del linguaggio stesso.

Sconsigliamo infatti di utilizzare versioni in END OF LIFE come la 5.2.

Ora vediamo nel dettaglio come funziona il PHP selector: trovere nel cPanel > Select PHP version

php_selector_user.png

 

Potrete poi selezionare la versione (la native è quella installata di default sul server di hosting) i moduli PHP desiderati e il gioco è fatto.

cpanel_php_version_select

 

phpselector21

 

Lo stesso vale per Plesk come potrete notare di seguito:

andiamo in Siti web e domini

Plesk_1

 

scegliamo Directory virtuali

plesk_3

 

successivamente Impostazioni PHP

plesk_4

 

e finalmente potremo selezionare la versione PHP che desideriamo utilizzare.

plesk_5

 

A questo punto non ci resta che augurarvi.. buon lavoro!